Support and Documentation

Getting started

This section describes how to set up a development environment for working with the starter theme.

System requirements

To install and run Styleguide, you need the following software:

  • Node.js version 8.11.3—available from Node.js.

  • gulp version 3.9.x—best to install using npm install -g gulp-cli.

  • Yarn version 1.7.0—available from Yarn's Installation.

Starter theme

To begin developing Brightspot themes, start with the Starter Theme. Assuming you have git installed, you can clone the theme using:

git clone https://github.com/perfectsense/brightspot-theme

If you don't have git installed, you can just Download the .zip.

The starter theme includes support for the following pages:

  • Article

  • Gallery

  • Video