Support and Documentation

Upgrading to latest virtual machine

The first time you run the script Vagrantfile, the script downloads a virtual machine. Vagrant caches the virtual machine, so you may eventually be using an unsupported version. If you receive runtime error messages, consider upgrading your version of the virtual machine by using the following procedure.

Procedure. To upgrade a virtual machine:
  1. In a terminal emulator, change to the directory containing the file Vagrantfile.

  2. Delete the cached version of the VM:

    vagrant box remove <name>
    
  3. Download the latest version of Vagrantfile:

    curl -o Vagrantfile https://s3.amazonaws.com/brightspot-vagrant/boxes/Vagrantfile
    
  4. Install Brightspot as described in Installing Brightspot on the virtual machine.